We’ve confirmed that the issue is caused by the recently released iPadOS version 17.7.7 (May 12, 2025). This is not specific to the SIE Kiosk app—multiple applications are being affected, as discussed in this Apple forum thread: https://discussions.apple.com/thread/256059474?sortBy=rank
Important: If you're using a 6th Generation iPad or older, we strongly recommend not upgrading to iPadOS 17.7.7 until further notice.
Posted May 14, 2025 - 19:29 PDT
Investigating
Reports of blank (white) screens being experienced on iPads running on iPadOS v17.7.7 have been received. The team is currently investigating this and will provide updates as soon as they become available.
Posted May 14, 2025 - 08:50 PDT
This incident affects: iPad App (Visitor Registration).