Kiosk signins are getting stuck in the Guest Sign Page

Incident Report for Sign In Enterprise

Identified

The issue has been associated with a recent back-end feature update that changed how documents are processed. The update has been rolled back for affected customers, which - along with previously provided workarounds - has resolved the issue for the customers.

We are continuing to troubleshoot to identify the root cause and ensure the behavior does not resurface when the feature update is reintroduced.
Posted Jan 08, 2026 - 20:20 PST

Update

Still being investigated. In the meantime, the following options have helped address the issue for some customers:

Option 1 - Update the Experience | Refresh Theme
Option 2 - Remove the Guest Sign node in the Experience, add it again, and select the same document
Option 3 - Uninstall the SIS VM app from the kiosk and reinstall

If you need any assistance in performing these steps, feel free to reach out to our Support Team (support@signinsolutions.com).
Posted Jan 07, 2026 - 10:00 PST

Investigating

We are aware of an issue where visitors are unable to sign in through the Kiosk app. Documents are not loading completely, which causes the sign-in process to hang. Our team is actively investigating the issue and working toward a resolution. We will provide an update as soon as more information becomes available.
Posted Jan 07, 2026 - 08:42 PST
This incident affects: iPad App (Visitor Registration).